Sheets & Dashboards Performance Issues

Incident
August 08, 2:31pm

Sheets & Dashboards Performance Issues

Status: closed
Start: August 08, 12:00pm
End: August 08, 2:31pm
Duration: 2 hours 30 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Investigating

August 08, 12:00pm

August 08, 12:00pm

We are currently investigating some customer reports of users being unable to load sheets and dashboards. We will provide an update in 30 minutes.

Monitoring

August 08, 12:27pm

August 08, 12:27pm

We have taken measures to mitigate and are monitoring the results.

Resolved

August 08, 2:31pm

August 08, 2:31pm

This incident has been resolved.