Smartsheet App Slow Performance

Incident
August 05, 5:46pm

Smartsheet App Slow Performance

Status: closed
Start: August 05, 10:27am
End: August 05, 5:46pm
Duration: 7 hours 18 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Investigating

August 05, 10:27am

August 05, 10:27am

We are currently investigating reports of slow performance in the Smartsheet App. We will provide an update in 60 minutes.

Identified

August 05, 11:08am

August 05, 11:08am

We have identified the issue and are taking actions to resolve.

Monitoring

August 05, 2:18pm

August 05, 2:18pm

A fix has been implemented and we are monitoring the results.

Resolved

August 05, 5:46pm

August 05, 5:46pm

This incident has been resolved.