Dashboard Loading Issues

Incident
April 15, 7:38pm

Dashboard Loading Issues

Status: closed
Start: April 15, 5:38pm
End: April 15, 7:38pm
Duration: 1 hour 59 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Investigating

April 15, 5:38pm

April 15, 5:38pm

We are currently investigating some customer reports of issues loading dashboards and dashboard widgets. We will provide an update in 60 minutes.

Monitoring

April 15, 5:44pm

April 15, 5:44pm

A fix has been implemented and we are monitoring to ensure continued stability of this feature.

Resolved

April 15, 7:38pm

April 15, 7:38pm

This incident has been resolved.