Smartsheet Intermittently Unavailable

Incident
March 07, 9:06am

Smartsheet Intermittently Unavailable

Status: in progress
Start: March 07, 7:28am
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Investigating

March 07, 7:28am

March 07, 7:28am

We are currently investigating some customer reports of delays and intermittent accessibility in sheets, reports, dashboards, workflows, and Admin Center. We will provide an update in 60 minutes.

Investigating

March 07, 8:27am

March 07, 8:27am

We are continuing to investigate the issue. We will provide an update in 60 minutes.

Monitoring

March 07, 9:06am

March 07, 9:06am

A fix has been implemented and all services are restored. We are continuing to monitor these features to ensure stability and performance.