Users unable to save sheets

Incident
June 26, 4:20pm

Users unable to save sheets

Status: closed
Start: June 26, 2:10pm
End: June 26, 4:20pm
Duration: 2 hours 9 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Investigating

June 26, 2:10pm

June 26, 2:10pm

We are investigating reports of some users being unable to save sheets. We will provide an update in 60 minutes.

Monitoring

June 26, 2:20pm

June 26, 2:20pm

Engineering has implemented a fix for this issue and we are monitoring the results.

Resolved

June 26, 4:20pm

June 26, 4:20pm

This incident has been resolved.