Reports of Slow Loading in Smartsheet App

Informational
June 23, 5:33pm

Reports of Slow Loading in Smartsheet App

Status: closed
Date: June 23, 3:33pm
End: June 23, 5:33pm
Duration: 2 hours
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Monitoring

June 23, 3:33pm

June 23, 3:33pm

We have identified an issue where users may have experienced slow load times. We are monitoring the service to ensure recovery.

Resolved

June 23, 5:33pm

June 23, 5:33pm

This incident has been resolved.