Smartsheet Unavailable

Incident
June 12, 11:57am

Smartsheet Unavailable

Status: closed
Start: June 12, 10:12am
End: June 12, 11:57am
Duration: 1 hour 44 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Investigating

June 12, 10:12am

June 12, 10:12am

We are investigating issues logging into Smartsheet and will provide an update within the next 30 minutes.

Investigating

June 12, 10:40am

June 12, 10:40am

The Smartsheet application is currently unavailable. We are continuing to investigate and will continue providing updates every 30 minutes. We will send another notification to subscribers with the next functional update.

Monitoring

June 12, 10:55am

June 12, 10:55am

The Smartsheet application is now available. A fix has been implemented and we are monitoring to ensure continued stability.

Resolved

June 12, 11:57am

June 12, 11:57am

The Smartsheet application continues to function normally. This incident has been resolved.