Forms unavailable

Incident
April 04, 5:52pm

Forms unavailable

Status: closed
Start: April 04, 5:15pm
End: April 04, 5:52pm
Duration: 37 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Conversations Mobile App Dashboards Forms Sharing Mobile/API Web Application
Investigating

April 04, 5:15pm

April 04, 5:15pm

We are currently investigating some customer reports of being unable to load forms. We will provide an update in 60 minutes.

Monitoring

April 04, 5:24pm

April 04, 5:24pm

A fix has been implemented and we are monitoring to ensure continued stability of this feature.

Resolved

April 04, 5:52pm

April 04, 5:52pm

This incident has been resolved.