Delays in Email Notifications

Incident
March 01, 9:26pm

Delays in Email Notifications

Status: closed
Start: March 01, 6:20pm
End: March 01, 9:26pm
Duration: 3 hours 5 minutes
Affected Components:
Collaboration & Communication Smartsheet System Generated Emails
Investigating

March 01, 6:20pm

March 01, 6:20pm

We are currently investigating some customer reports of delays in email notifications. We will provide an update in 60 minutes.

Monitoring

March 01, 7:21pm

March 01, 7:21pm

A fix has been implemented and we are monitoring to ensure continued stability of this feature.

Resolved

March 01, 9:26pm

March 01, 9:26pm

This incident has been resolved.