Some users are unable to load some sheets

Incident
November 15, 12:23pm

Some users are unable to load some sheets

Status: closed
Start: November 15, 10:11am
End: November 15, 12:23pm
Duration: 2 hours 11 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Web Application
Update

November 15, 10:11am

November 15, 10:11am

On November 15, 2022 from approximately 7AM to 9:30AM PST, we received reports that some customers were sometimes unable to load certain sheets. We implemented a fix at around 9:30AM, which resolved the issue.

Investigating

November 15, 10:11am

November 15, 10:11am

We are currently investigating customer reports of some sheets not loading consistently. We will provide an update in 60 minutes.

Monitoring

November 15, 11:36am

November 15, 11:36am

A fix has been implemented and we are monitoring to ensure continued stability of this feature.

Resolved

November 15, 12:23pm

November 15, 12:23pm

This incident has been resolved.