Service Issue Reported – EBSCO EBooks

Informational
November 07, 4:03pm

Service Issue Reported – EBSCO EBooks

Status: closed
Date: November 07, 3:43pm
End: November 07, 4:03pm
Duration: 19 minutes
Affected Components:
Teaching & Learning EBSCO (library database)
Investigating

November 07, 3:43pm

November 07, 3:43pm

We have received reports of an issue with EBSCO eBooks. Our engineering teams are currently investigating the issue and we will update this page when more information is available.

Resolved

November 07, 4:03pm

November 07, 4:03pm

This incident has been resolved.