Service Issue Reported – New EDS, Publication Finder, EBSCO Mobile

Incident
November 01, 4:23pm

Service Issue Reported – New EDS, Publication Finder, EBSCO Mobile

Status: closed
Start: November 01, 3:52pm
End: November 01, 4:23pm
Duration: 30 minutes
Affected Components:
Teaching & Learning EBSCO (library database)
Investigating

November 01, 3:52pm

November 01, 3:52pm

We have received reports of an issue with New EDS, Publication Finder, EBSCO Mobile App. Our engineering teams are currently investigating the issue and we will update this page when more information is available.

Investigating

November 01, 3:53pm

November 01, 3:53pm

We are continuing to investigate this issue.

Resolved

November 01, 4:23pm

November 01, 4:23pm

The issues customers reported with EBSCO Mobile App, New EDS, and Publication Finder are now resolved. If you continue to experience an issue please contact Customer Support. We apologize for the inconvenience.