Turnitin Emergency Maintenance 28th July, 2022

Under maintenance
July 28, 2:55am

Turnitin Emergency Maintenance 28th July, 2022

Status: closed
Start: July 27, 8:30pm
End: July 28, 2:55am
Duration: 6 hours 25 minutes
Affected Components:
Teaching & Learning Turnitin
Update

July 27, 8:30pm

July 27, 8:30pm

Turnitin will undergo an emergency maintenance on July 28th at 24:00 PDT (BST 8:00 28th of July, AEST 17:00 28th of July) [go to https://tinyurl.com/yjk86vje to find your local time]. During this time, there may be a minor loss of functionality for instructors. We regret any inconvenience this may cause.

Update

July 28, 2:01am

July 28, 2:01am

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Resolved

July 28, 2:55am

July 28, 2:55am

July 28th, 2022 Emergency Maintenance Completed. Thank you for your patience. The Emergency Maintenance occurred between the following times: PDT July 28th 00:28 - July 28th 00:33 BST: July 28th 08:28 - July 28th 08:33 AEST: July 28th 17:28 - July 28th 17:33 We regret any inconvenience this may have caused if you were impacted by today’s maintenance.