Some application emails are delayed

Incident
June 10, 11:40am

Some application emails are delayed

Status: closed
Start: June 10, 10:49am
End: June 10, 11:40am
Duration: 51 minutes
Affected Components:
Collaboration & Communication Smartsheet System Generated Emails
Update

June 10, 10:49am

June 10, 10:49am

On June 10th, 2022 between 6 am and 9:38 am PDT, customers saw a delay in receiving e-mails sent through @mentions, sharing notifications and workflow notifications. We addressed the issue by increasing the capacity of the email processing system. The last of the delayed emails were processed by 9:38 am PDT. We are making improvements based on our learnings from the incident to avoid similar incidents in the future.

Update

June 10, 10:49am

June 10, 10:49am

We are currently investigating an issue some users are experiencing with email notifications being delayed. We are investigating and will provide an update within the next 30 minutes.

Update

June 10, 11:18am

June 10, 11:18am

The issue has been identified and a fix has been implemented. We are monitoring the results.

Resolved

June 10, 11:40am

June 10, 11:40am

The fix has been implemented and the issue is now resolved.