App Slowness

Incident
May 25, 7:09pm

App Slowness

Status: closed
Start: May 25, 12:29pm
End: May 25, 7:09pm
Duration: 6 hours 40 minutes
Affected Components:
Collaboration & Communication Smartsheet Smartsheet Application Documents Conversations Document Builder Mobile App Proofing Panel and Requests Dashboards Uploading and Downloading Attachments Forms Sharing Mobile/API Web Application
Update

May 25, 12:29pm

May 25, 12:29pm

Starting at 12:15 am PDT 5/24 we received over 30 customer cases around app slowness, this spanned from sheet to dashboards and reports, general slowness across the application. The slowness cases continued through the morning and afternoon on 5/25. We resolved this by rolling back a scheduled release. The rollback was completed by 2:00 pm PDT. We continued monitoring customer reports, no new customer cases received post 2:41 pm PDT. The issue was resolved with the roll back.

Update

May 25, 12:29pm

May 25, 12:29pm

The engineering team is engaged and we are investigating slowness with the web application. We will provide an update in 60 minutes.

Update

May 25, 1:56pm

May 25, 1:56pm

We are continuing to investigate this issue. We will provide an update in 60 minutes.

Update

May 25, 3:14pm

May 25, 3:14pm

The issue has been identified and a fix is being implemented. We will provide an update in 60 minutes.

Update

May 25, 4:09pm

May 25, 4:09pm

The issue has been identified and a fix is being implemented. We will provide an update in 60 minutes.

Update

May 25, 5:03pm

May 25, 5:03pm

A fix has been implemented and we are monitoring the results.

Resolved

May 25, 7:09pm

May 25, 7:09pm

This incident has been resolved.