PowerSchool Applications System Maintenance May 14, 6am - 7am PDT

Under maintenance
May 16, 11:58am

PowerSchool Applications System Maintenance May 14, 6am - 7am PDT

Status: closed
Start: May 14, 8:00am
End: May 16, 11:58am
Duration: 2 days 3 hours 58 minutes
Affected Components:
Teaching & Learning Schoology
Update

May 14, 8:00am

May 14, 8:00am

This is a notice for an upcoming maintenance that is being conducted on multiple SaaS platform. There is downtime associated with this maintenance. Please see below details. Maintenance Window: Saturday, May, 14th 2022, 6:00 am – 7:00 am PDT Product: Applicant Tracking, BusinessPlus, eFinancePlus, Enrollment, eSchoolPlus, Perform, Performance Matters, PowerSchool SIS, Professional Learning, Records, Schoology Learning, SmartFind Express, Special Programs, Unified Insights, Naviance, HigherEd Platform Reason for Maintenance: We are completing maintenance of these PowerSchool Products. With this maintenance we are aiming to update configuration to improve your experience with these applications

Resolved

May 16, 11:58am

May 16, 11:58am

The scheduled maintenance has been completed.