Users may be intermittently unable to join group calls in Microsoft Teams from multiple devices

Incident
December 09, 6:06pm

Users may be intermittently unable to join group calls in Microsoft Teams from multiple devices

Status: closed
Start: December 07, 1:48pm
End: December 09, 6:06pm
Duration: 2 days 4 hours 17 minutes
Affected Components:
Collaboration & Communication Microsoft Teams
Update

December 07, 1:48pm

December 07, 1:48pm

Title: Users may be intermittently unable to join group calls in Microsoft Teams from multiple devices
User Impact: Users may be intermittently unable to join group calls in Microsoft Teams from multiple devices.
More info: As an example of impact, a user can connect through the desktop client. However, when the user attempts to connect on a separate connection method such as a mobile device, this may intermittently fail. Users can circumvent this issue by connecting through a Public Switched Telephone Network (PSTN) or only leveraging a single device.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.
Scope of impact: Your organization is affected by this event, and any user attempting to join a group call in Microsoft Teams from multiple devices is affected.

Update

December 07, 2:29pm

December 07, 2:29pm

More info: Our investigation has determined that a recent update to the group calling API intended to streamline endpoint communication processes caused a compatibility issue, resulting in impact. We've developed and validated a fix and we're aiming to have a deployment timeline by our next update.
Current status: Our investigation has determined that a recent update to the group calling API intended to streamline the endpoint transfer process contained a compatibility error, resulting in impact. We've developed and validated a fix which we believe will resolve this impact, and we're aiming to have a deployment timeline in our next update.
Scope of impact: Your organization is affected by this event, and any user attempting to join a group call in Microsoft Teams from multiple devices is affected.
Root cause: A recent update to the group calling API intended to streamline endpoint communication processes caused a compatibility issue, resulting in intermittent endpoint transfer failures.
Next update by: Tuesday, December 7, 2021, at 10:30 PM UTC

Update

December 07, 3:10pm

December 07, 3:10pm

More info: As an example of impact, a user can connect through the desktop client. However, when the user attempts to connect on a separate connection method such as a mobile device, this may intermittently fail. Users can circumvent this issue by connecting through a Public Switched Telephone Network (PSTN) or only leveraging a single device.
Current status: We've begun deployment of the fix to the affected environment. We anticipate the deployment will complete on Friday, November 10, 2021, after which we'll monitor to ensure impact is remediated. Some users may begin to experience relief as the fix progresses.
Scope of impact: Your organization is affected by this event, and any user attempting to join a group call in Microsoft Teams from multiple devices is affected.
Estimated time to resolve: We anticipate deployment of the fix to complete on Friday, November 10, 2021.
Root cause: A recent update to the group calling API intended to streamline endpoint communication processes caused a compatibility issue, resulting in intermittent endpoint transfer failures.
Next update by: Friday, December 10, 2021, at 8:00 PM UTC

Resolved

December 09, 6:06pm

December 09, 6:06pm

Title: Users may be intermittently unable to join group calls in Microsoft Teams from multiple devices
User Impact: Users may have been intermittently unable to join group calls in Microsoft Teams from multiple devices.
More info: As an example of impact, a user could have connected through the desktop client. However, when the user attempted to connect on a separate connection method such as a mobile device, this may have intermittently failed. Users could circumvent this issue by connecting through a Public Switched Telephone Network (PSTN) or only leveraging a single device.
Final status: Our deployment of the fix has completed, and we've confirmed after monitoring telemetry that impact is remediated.
Scope of impact: Your organization was affected by this event, and any user attempting to join a group call in Microsoft Teams from multiple devices was affected.
Start time: Monday, November 15, 2021, at 5:00 PM UTC
End time: Friday, December 10, 2021, at 12:06 AM UTC
Root cause: A recent update to the group calling API intended to streamline endpoint communication processes caused a compatibility issue, resulting in intermittent endpoint transfer failures.
Next steps: - We're reviewing the affecting update and our testing and validation procedures to identify how impact was missed and better prevent similar future occurrences.
This is the final update for the event.

Resolved

December 09, 6:06pm

December 09, 6:06pm

Resolved