Users are seeing incorrect presence status in Microsoft Teams

Incident
December 06, 2:57pm

Users are seeing incorrect presence status in Microsoft Teams

Status: closed
Start: December 06, 10:17am
End: December 06, 2:57pm
Duration: 4 hours 39 minutes
Affected Components:
Collaboration & Communication Microsoft Teams
Update

December 06, 10:17am

December 06, 10:17am

Title: Some users are seeing incorrect presence status in Microsoft Teams
User Impact: Users are seeing incorrect presence status in Microsoft Teams.
More info: Users may see presence status as 'offline' or 'unknown.'
Current status: We're analyzing service telemetry showing presence availability so we can better understand the origin of impact and determine our next troubleshooting steps.
Scope of impact: Your organization is affected by this event, and a subset of users may experience impact.
Next update by: Monday, December 6, 2021, at 5:30 PM UTC

Update

December 06, 11:34am

December 06, 11:34am

More info: Users may see presence status as 'offline' or 'unknown.'
Current status: Our analysis of service telemetry in parallel with assessment of newly implemented changes made to the service suggests that a recent update intended to optimize presence functionality may inadvertently be contributing to impact. We're continuing to verify this theory and are simultaneously determining our next steps to provide alleviation.
Scope of impact: A subset of users hosted out of the affected infrastructure may experience impact.
Next update by: Monday, December 6, 2021, at 8:00 PM UTC

Update

December 06, 12:56pm

December 06, 12:56pm

More info: Users may see presence status as 'offline' or 'unknown.'
Current status: We've identified through further investigation that the aforementioned presence update caused a discrepancy between the information needed to propagate users' presence and the cache information currently available, consequently inhibiting users from seeing correct presence across all Microsoft Teams connection methods. To alleviate impact, we've developed, tested, and initiated the deployment of an update to resolve the cache issue by eliminating the impacting discrepancy. We'll provide additional information regarding the fix's deployment status and estimated time to resolution via our next scheduled update.
Scope of impact: A subset of users hosted out of the affected infrastructure may experience impact.
Start time: Saturday, December 4, 2021, at 12:00 PM UTC
Root cause: A recent update intended to enhance presence functionality caused a discrepancy between the information needed to propagate users' presence and the information currently available in the cache, consequently inhibiting users from seeing correct presence across all Teams connection methods.
Next update by: Monday, December 6, 2021, at 10:00 PM UTC

Update

December 06, 2:27pm

December 06, 2:27pm

More info: Users may see presence status as 'offline' or 'unknown.'
Current status: We've confirmed via service telemetry that our change addressing the cache issue has already brought alleviation to a large portion of formerly affected users. We're continuing to monitor its deployment to confirm resolution of persisting impact, and we anticipate full remediation for all users by our next scheduled update.
Scope of impact: A subset of users hosted out of the affected infrastructure may experience impact.
Start time: Saturday, December 4, 2021, at 12:00 PM UTC
Root cause: A recent update intended to enhance presence functionality caused a discrepancy between the information needed to propagate users' presence and the information currently available in the cache, consequently inhibiting users from seeing correct presence across all Teams connection methods.
Next update by: Monday, December 6, 2021, at 10:00 PM UTC

Resolved

December 06, 2:57pm

December 06, 2:57pm

Title: Some users are seeing incorrect presence status in all Microsoft Teams connection methods
User Impact: Users were seeing incorrect presence status in all Microsoft Teams connection methods.
More info: Users may have seen presence status as 'offline' or 'unknown.'
Final status: Our investigation is complete, and we've verified through continued monitoring of service telemetry that our update to address the cache issue has resolved the problem for all previously impacted users.
Scope of impact: A subset of users hosted out of the affected infrastructure may have experienced impact.
Start time: Saturday, December 4, 2021, at 12:00 PM UTC
End time: Monday, December 6, 2021, at 8:57 PM UTC
Root cause: A recent update intended to enhance presence functionality caused a discrepancy between the information needed to propagate users' presence and the information available in the cache, consequently inhibiting users from seeing correct presence across all Teams connection methods.
Next steps: - We're assessing potential optimizations within our testing methodology to isolate and resolved future impact scenarios prior to deployment.
This is the final update for the event.

Resolved

December 06, 2:57pm

December 06, 2:57pm

Resolved