Admins may be unable to submit port and transfer requests for Public Switched Telephone Network (PSTN) numbers

Incident
December 01, 7:39pm

Admins may be unable to submit port and transfer requests for Public Switched Telephone Network (PSTN) numbers

Status: closed
Start: December 01, 7:06pm
End: December 01, 7:39pm
Duration: 32 minutes
Affected Components:
Collaboration & Communication Microsoft Teams
Update

December 01, 7:06pm

December 01, 7:06pm

Title: Admins may be unable to submit port and transfer requests for Public Switched Telephone Network (PSTN) numbers
User Impact: Admins may be unable to submit port and transfer requests for PSTN phone numbers in the Microsoft Teams admin center.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.
Scope of impact: This issue affects any admins attempting to port and transfer PSTN numbers in the Microsoft Teams admin center.

Resolved

December 01, 7:39pm

December 01, 7:39pm

Title: Admins may be unable to submit manual requests to the Telephone Number Services (TNS) Service Desk
User Impact: Admins may have been unable to submit manual requests to the TNS Service Desk in the Microsoft Teams admin center.
More info: - While we were focused on remediation, admins could go to the "Phone Numbers" page in the Microsoft Teams admin center and then select "Get phone number support".
- Manual actions outside of the United States and Canada included submitting port and transfer requests for Public Switched Telephone Network (PSTN) phone numbers.
- Manual actions within the United States and Canada included contacting the TNS Service Desk when having trouble purchasing net new phone numbers.
Final status: We've determined that an upstream telemetry update inadvertently resulted in impact to Microsoft Teams due to an unforeseen incompatibility. We've reverted the update and monitored the environment to confirm service is restored.
Scope of impact: This issue affected any admins attempting to submit manual requests to the TNS Service Desk in the Microsoft Teams admin center.
Start time: Wednesday, December 1, 2021, at 7:05 PM UTC
End time: Thursday, December 2, 2021, at 1:39 AM UTC
Root cause: An upstream telemetry update inadvertently resulted in the impact to Microsoft Teams due to an unforeseen incompatibility.
Next steps: - To help prevent similar impact in the future, we're further reviewing how we can improve our validation procedures to catch such compatibility issues before deployment.
This is the final update for the event.

Resolved

December 01, 7:39pm

December 01, 7:39pm

Resolved

Update

December 01, 7:39pm

December 01, 7:39pm

More info: - Manual actions outside of the United States and Canada include submitting port and transfer requests for PSTN phone numbers.
- Manual actions within the United States and Canada include contacting the TNS Service Desk when having trouble purchasing net new phone numbers.
Current status: We're analyzing service logs to determine the source of the issue.
Scope of impact: This issue affects any admins attempting to submit manual requests to the TNS Service Desk in the Microsoft Teams admin center.
Next update by: Thursday, December 2, 2021, at 2:30 AM UTC