Some users may be unable to get location information for incoming emergency calls within Microsoft Teams

Incident
December 01, 11:45am

Some users may be unable to get location information for incoming emergency calls within Microsoft Teams

Status: closed
Start: December 01, 7:51am
End: December 01, 11:45am
Duration: 3 hours 53 minutes
Affected Components:
Collaboration & Communication Microsoft Teams
Update

December 01, 7:51am

December 01, 7:51am

Title: Some users may be unable to get location information for incoming emergency calls within Microsoft Teams
User Impact: Users may be unable to get location information for incoming emergency calls within Microsoft Teams.
Current status: We're analyzing service monitoring telemetry to identify what is causing the issue and establish a fix.
Scope of impact: Impact is specific to a portion of users located across Europe.
Next update by: Wednesday, December 1, 2021, at 4:00 PM UTC

Update

December 01, 9:25am

December 01, 9:25am

Current status: We've identified that an unexpectedly high volume of user traffic is resulting in resource contention, causing requests to timeout. We've redirected user traffic to alternate infrastructure and confirmed, after a period of monitoring, that the service has restored for impacted users in Europe. We're analyzing service logs to determine why impact has not been alleviated across all regions, specifically for users based in North America.
Scope of impact: Impact is specific to a portion of users located across Europe and North America.
Start time: Thursday, December 2, 2021, at 1:36 PM UTC
Root cause: A unexpected surge in user activity caused a CPU spike, causing impact.
Next update by: Wednesday, December 1, 2021, at 5:30 PM UTC

Update

December 01, 11:29am

December 01, 11:29am

Current status: We're continuing to redirect user traffic to an alternate subsection of service infrastructure which we're expecting will remediate impact.
Scope of impact: Impact is specific to a subsection of users located across North America, and previously impacted users located in Europe.
Start time: Wednesday, December 1, 2021, at 1:36 PM UTC
Next update by: Wednesday, December 1, 2021, at 7:30 PM UTC

Resolved

December 01, 11:45am

December 01, 11:45am

Title: Some users may be unable to get location information for emergency calls within Microsoft Teams
User Impact: Users may have been unable to get location information for emergency calls within Microsoft Teams.
Final status: We've confirmed that a subsection of service infrastructure that facilitates location information for emergency calls with Microsoft Teams had fallen below our manageable service performance thresholds, resulting in impact. We've rerouted traffic to an alternate subsection of service infrastructure to remediate impact.
Scope of impact: Impact was specific to a subsection of users located across North America and Europe.
Start time: Wednesday, December 1, 2021, at 1:07 PM UTC
End time: Wednesday, December 1, 2021, at 5:45 PM UTC
Root cause: A subsection of service infrastructure that facilitates location information for emergency calls with Microsoft Teams dropped below our manageable service performance thresholds, resulting in impact.
Next steps: - We're analyzing performance data and trends on the affected systems to determine why levels dropped below our manageable thresholds, and to help prevent this problem from happening again.
This is the final update for the event.

Resolved

December 01, 11:45am

December 01, 11:45am

Resolved