Producers in Microsoft Teams live events are unable to preview a presenter’s content in the source tray

Incident
December 02, 12:44pm

Producers in Microsoft Teams live events are unable to preview a presenter’s content in the source tray

Status: closed
Start: November 25, 3:12pm
End: December 02, 12:44pm
Duration: 6 days 21 hours 31 minutes
Affected Components:
Collaboration & Communication Microsoft Teams
Update

November 25, 3:12pm

November 25, 3:12pm

Title: Producers in Microsoft Teams live events are unable to preview a presenter’s screen
User Impact: Users who are producing Microsoft Teams live events are unable to preview a presenter’s screen.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.
Scope of impact: All users producing Microsoft Teams live events are impacted.

Update

November 25, 3:31pm

November 25, 3:31pm

Current status: We're reviewing similar instances of impact in parallel with support case information, including screenshots of impact and Microsoft Teams logs, to identify potential sources of impact.
Scope of impact: All users producing Microsoft Teams live events are impacted.
Next update by: Thursday, November 25, 2021, at 11:00 PM UTC

Update

November 25, 4:41pm

November 25, 4:41pm

More info: Producers are able to see a presenter’s content or video in the source tray; however, once they are clicked to queue up the presenter, the preview in the source tray goes black.
The preview will remain if the presenters are not clicked on.
Impact is specific to the source tray. As a workaround, producers experiencing impact can click on the blank thumbnail in the source tray to receive a detailed, larger thumbnail in the top half of the live event screen to preview presenter content and video.
Current status: We've confirmed that a recent update introduced a code regression which impacts source tray rendering during live events. We're preparing a fix which will undergo testing and validation as a potential remediating action to resolve the issue.
Scope of impact: All users producing Microsoft Teams live events are impacted.
Start time: Wednesday, November 17, 2021, at 8:00 PM UTC
Root cause: A recent update introduced a code regression which impacts source tray rendering during live events.
Next update by: Tuesday, November 30, 2021, at 12:30 AM UTC

Update

November 29, 4:38pm

November 29, 4:38pm

More info: Producers are able to see a presenter’s content or video in the source tray; however, once they are clicked to queue up the presenter, the preview in the source tray goes black.
The preview will remain if the presenters are not clicked on.
Impact is specific to the source tray. As a workaround, producers experiencing impact can click on the blank thumbnail in the source tray to receive a detailed, larger thumbnail in the top half of the live event screen to preview presenter content and video.
Current status: We've completed our development and validation, and have confirmed that the fix will be a viable solution for resolving impact. We've begun deployment of the fix which will progressively resolve impact for affected users as it reaches their environment. We're expect the fix deployment to complete and for impact to be resolved by Thursday, December 2, 2021, at approximately 10:00 PM UTC.
Scope of impact: All users producing Microsoft Teams live events are impacted.
Start time: Wednesday, November 17, 2021, at 8:00 PM UTC
Estimated time to resolve: Based on current deployment progress, we expect this problem to be resolved within the next three days.
Root cause: A recent update introduced a code regression which impacts source tray rendering during live events.
Next update by: Friday, December 3, 2021, at 12:00 AM UTC

Resolved

December 02, 12:44pm

December 02, 12:44pm

Title: Producers in Microsoft Teams live events are unable to preview a presenter’s content in the source tray
User Impact: Users who were producing Microsoft Teams live events were unable to preview a presenter’s content using the source tray.
More info: Producers were able to see a presenter’s content or video in the source tray; however, once they were clicked to queue up the presenter, the preview in the source tray went black.
The preview would remain if the presenters were not clicked on.
Impact was specific to the source tray. As a workaround, producers experiencing impact could click on the blank thumbnail in the source tray to receive a detailed, larger thumbnail in the top half of the live event screen to preview presenter content and video.
Final status: We've completed deployment of the fix to the affected environment and confirmed with users that impact is remediated.
Scope of impact: All users producing Microsoft Teams live events were impacted.
Start time: Wednesday, November 17, 2021, at 8:00 PM UTC
End time: Thursday, December 2, 2021, at 6:44 PM UTC
Root cause: A recent update introduced a code regression which impacted source tray rendering during live events.
Next steps: - We're reviewing our update procedures to better identify similar live event issues during our development and testing cycles.
This is the final update for the event.

Resolved

December 02, 12:44pm

December 02, 12:44pm

Resolved