Users can't open non-Office file lists from modern SharePoint Online sites

Incident
November 06, 11:00am

Users can't open non-Office file lists from modern SharePoint Online sites

Status: closed
Start: November 04, 11:47am
End: November 06, 11:00am
Duration: 1 day 23 hours 12 minutes
Affected Components:
Collaboration & Communication SharePoint (The Hub)
Update

November 04, 11:47am

November 04, 11:47am

Title: Users can't open non-Office file lists from modern SharePoint Online sites
User Impact: Users can't open non-Office file lists from modern SharePoint Online sites.
More info: While we're working to investigate and resolve this issue, users can open non-Office file lists from SharePoint Online sites using the classic experience.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Update

November 04, 12:04pm

November 04, 12:04pm

More info: While we're working to investigate and resolve this issue, users can open non-Office file lists from SharePoint Online sites using the classic experience.
Current status: We're reviewing browser captures and network traces provided by affected users to determine the underlying cause of impact and develop actions to mitigate impact.
Scope of impact: Any user on the modern experience attempting to open non-Office file lists may be impacted by this issue.
Next update by: Thursday, November 4, 2021, at 6:30 PM UTC

Update

November 04, 1:17pm

November 04, 1:17pm

More info: While we're working to investigate and resolve this issue, users can open non-Office file lists from SharePoint Online sites using the classic experience.
Current status: Our review of the provided traces indicates that a recent service update contained an error which may be causing impact. We're reviewing the content of the update to confirm the cause and develop a mitigation strategy.
Scope of impact: Any user on the modern experience attempting to open non-Office file lists may be impacted by this issue.
Next update by: Thursday, November 4, 2021, at 8:30 PM UTC

Update

November 04, 2:56pm

November 04, 2:56pm

More info: Impacted non-Office file types include, but are not limited to, PDF, JPEG, and PNG.
While we're working to resolve this issue, users can open non-Office files from SharePoint Online lists via the classic experience.
Current status: We've confirmed that a recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact. We've developed a fix and are performing internal tests to validate its efficacy.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may be impacted by this issue.
Preliminary root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next update by: Thursday, November 4, 2021, at 10:00 PM UTC

Update

November 04, 4:56pm

November 04, 4:56pm

More info: Impacted non-Office file types include, but are not limited to, PDF, JPEG, and PNG.
While we're working to resolve this issue, users can open non-Office files from SharePoint Online lists via the classic experience.
Current status: We're in the final phases of preparing the fix and expect the deployment process to begin within the next two hours. Once initiated, we estimate it will take 24 hours to complete as the fix is safely deployed through our change management process.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may be impacted by this issue.
Start time: Tuesday, November 2, 2021, at 10:40 PM UTC
Preliminary root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next update by: Thursday, November 4, 2021, at 11:30 PM UTC

Update

November 04, 6:05pm

November 04, 6:05pm

More info: Impacted non-Office file types include, but are not limited to, PDF, JPEG, and PNG.
While we're working to resolve this issue, users can open non-Office files from SharePoint Online lists via the classic experience.
Current status: We've identified errors within the fix that are preventing us from initiating deployment. We're working to investigate and address these errors as quickly as possible.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may be impacted by this issue.
Start time: Tuesday, November 2, 2021, at 10:40 PM UTC
Preliminary root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next update by: Friday, November 5, 2021, at 2:30 AM UTC

Update

November 04, 8:49pm

November 04, 8:49pm

More info: Impacted non-Office file types include, but are not limited to, PDF, JPEG, and PNG.
While we're working to resolve this issue, users can open non-Office files from SharePoint Online lists via the classic experience.
Current status: We’ve successfully addressed the issues that blocked us from deploying the fix. We’ve begun deployment to our internal and a subset of impacted infrastructure to validate that the fix will properly resolve the issue prior to pushing the fix to the remaining environments. We expect our validation process to take approximately three hours.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may be impacted by this issue.
Start time: Tuesday, November 2, 2021, at 10:40 PM UTC
Preliminary root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next update by: Friday, November 5, 2021, at 5:30 AM UTC

Update

November 04, 11:09pm

November 04, 11:09pm

More info: Impacted non-Office file types include, but are not limited to, PDF, JPEG, and PNG.
While we're working to resolve this issue, users can open non-Office files from SharePoint Online lists via the classic experience.
Current status: We've completed our validation process and confirmed that the fix will properly resolve the issue as expected. We've begun deployment to the remaining impacted environments and we will provide a detailed timeline by our next update.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may be impacted by this issue.
Start time: Tuesday, November 2, 2021, at 10:40 PM UTC
Preliminary root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next update by: Friday, November 5, 2021, at 5:30 PM UTC

Update

November 05, 11:36am

November 05, 11:36am

More info: Impacted non-Office file types include, but are not limited to, PDF, JPEG, and PNG.
While we're working to resolve this issue, users can open non-Office files from SharePoint Online lists via the classic experience.
Current status: We're closely monitoring the fix deployment as it reaches the remaining impacted environments. We’ve reached approximately 72% completion for the impacted infrastructure, and many customers will have already experienced remediation as the deployment has saturated in their environment.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may be impacted by this issue.
Start time: Tuesday, November 2, 2021, at 10:40 PM UTC
Root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next update by: Saturday, November 6, 2021, at 2:30 AM UTC

Update

November 05, 9:04pm

November 05, 9:04pm

More info: Impacted non-Office file types include, but are not limited to, PDF, JPEG, and PNG.
While we're working to resolve this issue, users can open non-Office files from SharePoint Online lists via the classic experience.
Current status: Our deployment has reached approximately 98 percent completion for the impacted infrastructure, and we’ve confirmed that majority of customers will or are experiencing remediation. We’ll continue our extensive monitoring while deployment reaches the remaining environments.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may be impacted by this issue.
Start time: Tuesday, November 2, 2021, at 10:40 PM UTC
Root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next update by: Saturday, November 6, 2021, at 6:00 PM UTC

Resolved

November 06, 11:00am

November 06, 11:00am

Title: Users can't open non-Office files from SharePoint Online lists in the modern experience
User Impact: Users were unable to open non-Office files from SharePoint Online lists in the modern experience.
More info: Impacted non-Office file types included, but were not limited to, PDF, JPEG, and PNG.
While we were working to resolve this issue, users could have opened non-Office files from SharePoint Online lists via the classic experience.
Final status: The deployment has reached full saturation and we’ve validated via internal monitoring that service has been restored.
Scope of impact: Any user hosted on the affected infrastructure using the modern experience attempting to open non-Office files from SharePoint Online lists may have been impacted by this issue.
Start time: Tuesday, November 2, 2021, at 10:40 PM UTC
End time: Saturday, November 6, 2021, at 4:00 PM UTC
Preliminary root cause: A recently deployed change intended to optimize video URL routing within the SharePoint Online service introduced a code problem that has resulted in impact.
Next steps: - We're reviewing our video URL routing updates to determine what caused the code issue and prevent similar incidents in the future.
We'll publish a post-incident report within five business days.

Resolved

November 06, 11:00am

November 06, 11:00am

Resolved