Users can't see digital signatures within .pdf files when using the SharePoint Online previewer

Incident
October 11, 5:00pm

Users can't see digital signatures within .pdf files when using the SharePoint Online previewer

Status: closed
Start: October 07, 10:35am
End: October 11, 5:00pm
Duration: 4 days 6 hours 24 minutes
Affected Components:
Collaboration & Communication SharePoint (The Hub)
Update

October 07, 10:35am

October 07, 10:35am

Title: Users can't see digital signatures within .pdf files when using the SharePoint Online previewer
User Impact: Users can't see digital signatures within .pdf files when using the SharePoint Online previewer.
More info: Impact is specific to the digital signatures within the previewer, the rest of the content is visible. Users can see the signatures after downloading the file.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Update

October 07, 10:49am

October 07, 10:49am

More info: Impact is specific to the digital signatures within the previewer, the rest of the content is visible. Users can see the signatures after downloading the file.
Current status: We're reviewing the SharePoint Online .pdf file previewing code to assist in the root cause investigation.
Scope of impact: Any user attempting to view digital signatures within .pdf files using the SharePoint Online previewer is impacted.
Next update by: Thursday, October 7, 2021, at 5:00 PM UTC

Update

October 07, 11:54am

October 07, 11:54am

More info: Impact is specific to the digital signatures within the previewer; the rest of the content is visible. Users can see the signatures after downloading the file. Users can also view the digital signatures by using the "Open in Browser" feature.
Current status: We're continuing our review of the previewer code to isolate the underlying cause and develop mitigation actions.
Scope of impact: Any user attempting to view digital signatures within .pdf files using the SharePoint Online previewer is impacted.
Next update by: Thursday, October 7, 2021, at 7:00 PM UTC

Update

October 07, 1:08pm

October 07, 1:08pm

More info: Impact is specific to the digital signatures within the previewer; the rest of the content is visible. Users can see the signatures after downloading the file. Users can also view the digital signatures by using the "Open in Browser" feature.
Current status: Our investigation has confirmed that a recent Javascript update contained a configuration error, resulting in impact. We're in the process of developing a fix and expect to have a mitigation timeline by the next scheduled update.
Scope of impact: Any user attempting to view digital signatures within .pdf files using the SharePoint Online previewer is impacted.
Start time: Tuesday, September 14, 2021, at 1:00 PM UTC
Root cause: A recent Javascript update contained a configuration issue, resulting in impact.
Next update by: Friday, October 8, 2021, at 2:30 AM UTC

Update

October 07, 8:34pm

October 07, 8:34pm

More info: Impact is specific to the digital signatures within the previewer; the rest of the content is visible. Users can see the signatures after downloading the file. Users can also view the digital signatures by using the "Open in Browser" feature.
Current status: We've developed and deployed the fix. We're monitoring its progress and expect service will be restored by Tuesday, October 12, 2021.
Scope of impact: Any user attempting to view digital signatures within .pdf files using the SharePoint Online previewer is impacted.
Start time: Tuesday, September 14, 2021, at 1:00 PM UTC
Estimated time to resolve: We expect the fix will finish deploying and service will be restored by Tuesday, October 12, 2021.
Root cause: A recent Javascript update contained a configuration issue, resulting in impact.
Next update by: Friday, October 8, 2021, at 10:30 PM UTC

Update

October 08, 4:06pm

October 08, 4:06pm

More info: Impact is specific to the digital signatures within the previewer; the rest of the content is visible. Users can see the signatures after downloading the file. Users can also view the digital signatures by using the "Open in Browser" feature.
Current status: We've confirmed that deployment of the fix has reached 50 percent of the affected environment, and continue to expect deployment to complete to resolve this issue ​by Tuesday, October 12, 2021
Scope of impact: Any user attempting to view digital signatures within .pdf files using the SharePoint Online previewer is impacted.
Start time: Tuesday, September 14, 2021, at 1:00 PM UTC
Estimated time to resolve: We expect the fix will finish deploying and service will be restored by Tuesday, October 12, 2021.
Root cause: A recent Javascript update contained a configuration issue, resulting in impact.
Next update by: Tuesday, October 12, 2021, at 8:00 PM UTC

Resolved

October 11, 5:00pm

October 11, 5:00pm

Title: Users can't see digital signatures within .pdf files when using the SharePoint Online previewer
User Impact: Users couldn't see digital signatures within .pdf files when using the SharePoint Online previewer.
More info: Impact was specific to the digital signatures within the previewer; the rest of the content was visible. Users could have seen the signatures after downloading the file or by using the "Open in Browser" feature.
Final status: We've confirmed that the fix has completed deployment and verified via telemetry and customer report that this has mitigated impact.
Scope of impact: Any user who attempted to view digital signatures within .pdf files using the SharePoint Online previewer experienced impact.
Start time: Tuesday, September 14, 2021, at 1:00 PM UTC
End time: Monday, October 11, 2021, at 10:00 PM UTC
Root cause: A recent JavaScript update contained a configuration issue which resulted in impact.
Next steps: - We're reviewing our JavaScript update procedures to better identify similar issues during our development and testing cycles.
This is the final update for the event.

Resolved

October 11, 5:00pm

October 11, 5:00pm

Resolved