Some users may be unable to create office documents utilising the powerapps tool within the SharePoint Online service

Incident
September 30, 3:33pm

Some users may be unable to create office documents utilising the powerapps tool within the SharePoint Online service

Status: closed
Start: September 30, 6:48am
End: September 30, 3:33pm
Duration: 8 hours 44 minutes
Affected Components:
Collaboration & Communication SharePoint (The Hub)
Update

September 30, 6:48am

September 30, 6:48am

Title: Some users may be unable to create .docx files within the SharePoint Online service
User Impact: Users may be unable to create .docx files within the SharePoint Online service.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.

Update

September 30, 7:31am

September 30, 7:31am

User impact: Users may be unable to create office documents utilising the powerautomate tool within the SharePoint Online service.
More info: This issue occurs when the 'allow chunking' option is enabled whilst attempting to create with content.
As a workaround, users are able to circumvent the issue by disabling the 'allow chunking' option and then splitting the "create file" and "update file" into two steps.
Current status: We're attempting to reproduce the issue in our internal testing environment, to help identify the root cause and develop a mitigation plan.
Scope of impact: Impact is specific to a subset of users who are served through the affected infrastructure.
Next update by: Thursday, September 30, 2021, at 7:00 PM UTC

Update

September 30, 12:48pm

September 30, 12:48pm

More info: This issue occurs when the 'Allow Chunking' option is enabled.
As a workaround, users can circumvent the issue by disabling the 'Allow Chunking' option and then splitting the "create file" and "update file" into two steps.
Current status: We've successfully reproduced the issue internally and our investigation indicates impact was caused by a recent API update which changed the way file storage is accessed. We're working to revert the change in a test environment to confirm this is the root cause prior to expanding to all impacted infrastructure.
Scope of impact: Impact is specific to users creating documents with "Allow Chunking' enabled.
Next update by: Thursday, September 30, 2021, at 10:30 PM UTC

Resolved

September 30, 3:33pm

September 30, 3:33pm

Title: Users can’t create Microsoft Office files using the Power Automate tool within SharePoint Online
User Impact: Users were unable to create Microsoft Office files using the Power Automate tool within SharePoint Online.
More info: This issue occurred when the 'Allow Chunking' option was enabled.
As a workaround, users could have circumvented the issue by disabling the 'Allow Chunking' option and then splitting the "create file" and "update file" into two steps.
Final status: We've reverted the change for all impacted infrastructure after successfully testing it in our internal environments and confirmed with affected users that impact has been mitigated.
Scope of impact: Impact was specific to users who created Microsoft Office files with "Allow Chunking' enabled.
Start time: Friday, September 24, 2021, at 9:26 AM UTC
End time: Thursday, September 30, 2021, at 8:33 PM UTC
Root cause: A recent API update which changed the way file storage is accessed resulted in impact.
Next steps: - We're reviewing our API update procedures to find ways to prevent this problem from happening again.
This is the final update for the event.

Resolved

September 30, 3:33pm

September 30, 3:33pm

Resolved