Users can't automate Power Automate items in their document libraries within SharePoint Online

Incident
September 02, 12:30pm

Users can't automate Power Automate items in their document libraries within SharePoint Online

Status: closed
Start: September 02, 8:42am
End: September 02, 12:30pm
Duration: 3 hours 47 minutes
Affected Components:
SharePoint (The Hub)
Update

September 02, 8:42am

September 02, 8:42am

Title: Some users are unable to automate Power Automate items in their document library within SharePoint Online
User Impact: Users are unable to automate Power Automate items in their document library within SharePoint Online.
Current status: We're reviewing the details provided in the support case and our internal reproduction of the issue to determine the root cause of impact.
Scope of impact: This issue impacts any user automating items in Power Automate.
Next update by: Thursday, September 2, 2021, at 7:30 PM UTC

Resolved

September 02, 12:30pm

September 02, 12:30pm

Final status: We determined that impact was caused by a recent service update which contained a change that altered the way category names are defined. We've reverted the change and confirmed mitigation with affected users.
Scope of impact: This issue may have impacted any user.
Start time: Thursday, September 2, 2021, at 3:02 AM UTC
End time: Thursday, September 2, 2021, at 5:30 PM UTC
Root cause: A recent service update intended to change the method category names are defined contained a code issue that inadvertently caused impact.
Next steps: - We're reviewing the category name definition code changes to isolate the impacting change to better identify similar issues within the validation process in the future.
This is the final update for the event.