Users can't modify the layout of SharePoint Online modern sites that have web parts

Incident
August 20, 12:56pm

Users can't modify the layout of SharePoint Online modern sites that have web parts

Status: closed
Start: August 20, 11:07am
End: August 20, 12:56pm
Duration: 1 hour 48 minutes
Affected Components:
SharePoint (The Hub)
Update

August 20, 11:07am

August 20, 11:07am

Title: Users can't modify the layout of SharePoint Online modern sites that have web parts
User Impact: Users are unable to modify the layout of SharePoint Online modern sites that have web parts.
More info: When users attempt to edit the desired section, they receive an error stating "No settings to change for this web part."
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes.
Scope of impact: Impact may occur for any user attempting to modify the layout of SharePoint Online modern sites that have web parts.

Update

August 20, 11:30am

August 20, 11:30am

More info: When users attempt to edit the desired section, they receive an error stating "No settings to change for this web part."
Current status: We're investigating available diagnostic data, such as any recent changes that may have contributed to this impact, in order to isolate the source of this issue and identify troubleshooting actions.
Scope of impact: Impact may occur for any user attempting to modify the layout of SharePoint Online modern sites that have web parts.
Next update by: Friday, August 20, 2021, at 5:30 PM UTC

Update

August 20, 12:13pm

August 20, 12:13pm

More info: When users attempt to edit the desired section, they receive an error stating "No settings to change for this web part."
Current status: We've identified a recent change that may have resulted in the impact, and we're disabling this flight in our test environment to confirm our findings and determine next steps.
Scope of impact: Impact may occur for any user attempting to modify the layout of SharePoint Online modern sites that have web parts.
Next update by: Friday, August 20, 2021, at 7:30 PM UTC

Resolved

August 20, 12:56pm

August 20, 12:56pm

More info: When users attempted to edit the desired section, they received an error stating "No settings to change for this web part."
Final status: We've identified that a recent change intended to update the Canvas Zone SharePoint Online library unexpectedly resulted in impact. We've disabled this offending change and after monitoring the service and verifying with affected users, we've ensured that this action has successfully resolved the problem.
Scope of impact: Impact may have occurred for any user attempting to modify the layout of SharePoint Online modern sites that have web parts.
Start time: Wednesday, August 18, 2021, at 11:00 PM UTC
End time: Friday, August 20, 2021, at 5:56 PM UTC
Root cause: A recent change intended to update the Canvas Zone SharePoint Online library unexpectedly resulted in impact.
Next steps: - We're investigating why the recent change intended to update the Canvas Zone SharePoint Online library resulted in impact to prevent this problem from happening again in the future. - We’re also assessing why the problem wasn’t caught prior to deploying the update so that we can improve our update testing procedures.
This is the final update for the event.