Mac users may be unable to sign into or run multiple OneDrive accounts on a single device

Incident
September 16, 7:00pm

Mac users may be unable to sign into or run multiple OneDrive accounts on a single device

Status: closed
Start: September 14, 11:54am
End: September 16, 7:00pm
Duration: 2 days 7 hours 5 minutes
Affected Components:
OneDrive
Update

September 14, 11:54am

September 14, 11:54am

Title: Mac users may be unable to sign into or run multiple OneDrive accounts on a single device
User Impact: Mac users may be unable to sign into or run multiple OneDrive accounts on a single device.
More info: This problem mostly affects users attempting to sign into both a personal account and a business account on the same device, but also impacts users signing into two business accounts. The issue only impacts users who have updated their devices to macOS 11.6. The issue also impacts both the OneDrive for Mac standalone sync client and the OneDrive on the Mac app acquired through the App Store.
Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 60 minutes.
Scope of impact: This issue could impact any of your Mac users who recently updated to macOS 11.6 and are attempting to sign into multiple OneDrive accounts on the same device.

Update

September 14, 12:55pm

September 14, 12:55pm

More info: This problem mostly affects users attempting to sign into both a personal account and a business account on the same device, but also impacts users signing into two business accounts. The issue only impacts users who have updated their devices to macOS 11.6. The issue also impacts both the OneDrive for Mac standalone sync client and the OneDrive on the Mac app acquired through the App Store.
Current status: We're reviewing system logs to determine if the macOS update is a contributing factor for this issue.
Scope of impact: This issue could impact any of your Mac users who recently updated to macOS 11.6 and are attempting to sign into multiple OneDrive accounts on the same device.
Next update by: Tuesday, September 14, 2021, at 9:00 PM UTC

Update

September 14, 3:58pm

September 14, 3:58pm

More info: This problem mostly affects users attempting to sign into both a personal account and a business account on the same device, but also impacts users signing into two business accounts. The issue only impacts users who have updated their devices to macOS 11.6. The issue also impacts both the OneDrive for Mac standalone sync client and the OneDrive on the Mac app acquired through the App Store.
Current status: We're working with Apple to better understand multi-account OneDrive for Business compatibility issues for Mac devices that started with the release and adoption of macOS 11.6 to better understand the underlying cause and to develop a solution.
Scope of impact: This issue could impact any of your Mac users who recently updated to macOS 11.6 and are attempting to sign into multiple OneDrive accounts on the same device.
Next update by: Wednesday, September 15, 2021, at 10:00 PM UTC

Update

September 15, 3:22pm

September 15, 3:22pm

More info: This problem mostly affects users attempting to sign into both a personal account and a business account on the same device, but also impacts users signing into two business accounts. The issue only impacts users who have updated their devices to macOS 11.6. The issue also impacts both the OneDrive for Mac standalone sync client and the OneDrive on the Mac app acquired through the App Store.
Current status: We've developed and are validating a temporary fix for the OneDrive for Mac standalone sync client that will allow affected users to again utilize multiple OneDrive accounts, both personal and business, on the same macOS 11.6 updated device. Once testing and validation is complete, we'll provide an estimate on the deployment timeline. In parallel, we're looking into workarounds for users that leverage the OneDrive on the Mac app acquired through the App Store.
Scope of impact: This issue could impact any of your Mac users who recently updated to macOS 11.6 and are attempting to sign into multiple OneDrive accounts on the same device.
Next update by: Thursday, September 16, 2021, at 1:00 AM UTC

Update

September 15, 6:32pm

September 15, 6:32pm

More info: This problem mostly affects users attempting to sign into both a personal account and a business account on the same device, but also impacts users signing into two business accounts. The issue only impacts users who have updated their devices to macOS 11.6. The issue also impacts both the OneDrive for Mac standalone sync client and the OneDrive on the Mac app acquired through the App Store.
Current status: We've developed and are validating a temporary fix for the OneDrive for Mac standalone sync client that will allow affected users to again utilize multiple OneDrive accounts, both personal and business, on the same macOS 11.6 updated device. Once testing and validation is complete, we'll provide an estimate on the deployment timeline. In parallel, we're looking into workarounds for users that leverage the OneDrive app on macOS acquired through the App Store.
Scope of impact: This issue could impact any of your Mac users who recently updated to macOS 11.6 and are attempting to sign into multiple OneDrive accounts on the same device.
Start time: Monday, September 13, 2021, at 7:00 AM UTC
Next update by: Thursday, September 16, 2021, at 9:00 PM UTC

Update

September 16, 1:48pm

September 16, 1:48pm

More info: This problem mostly affects users attempting to sign into both a personal account and a business account on the same device, but also impacts users signing into two business accounts. The issue only impacts users who have updated their devices to macOS 11.6. The issue also impacts both the OneDrive for Mac standalone sync client and the OneDrive on the Mac app acquired through the App Store.
OneDrive for Mac standalone sync client users can manually download the updated build with a fix if they haven't automatically received it from the following link: https://oneclient.sfx.ms/Mac/Prod/21.160.0808.0004/OneDrive.zip
Current status: The OneDrive for Mac standalone sync client fix has completed and most users should have automatically received this update, although it may take a few more hours to reach some users that haven't yet received it. Users can also manually download the updated build that includes the fix at: https://oneclient.sfx.ms/Mac/Prod/21.160.0808.0004/OneDrive.zip. We're continuing to review how the OneDrive app on macOS acquired through the App Store is specifically affected by this problem.
Scope of impact: This issue could impact any of your Mac users who recently updated to macOS 11.6 and are attempting to sign into multiple OneDrive accounts on the same device.
Start time: Monday, September 13, 2021, at 7:00 AM UTC
Next update by: Friday, September 17, 2021, at 9:30 PM UTC

Resolved

September 16, 7:00pm

September 16, 7:00pm

OneDrive for Mac standalone sync client users could have manually downloaded the updated build with a fix if they hadn't automatically received it from the following link: https://oneclient.sfx.ms/Mac/Prod/21.160.0808.0004/OneDrive.zip
Final status: We've developed and deployed an additional fix for the OneDrive app through the App Store that is now available and impacted users can manually update their app to immediately resolve this issue. As previously mentioned, the OneDrive for Mac standalone sync client fix has been completed and users can manually download the updated build that includes the fix at: https://oneclient.sfx.ms/Mac/Prod/21.160.0808.0004/OneDrive.zip if their clients aren't already updated automatically.
Scope of impact: This issue could have impacted any of your Mac users who recently updated to macOS 11.6 and were attempting to sign into multiple OneDrive accounts on the same device.
Start time: Monday, September 13, 2021, at 7:00 AM UTC
End time: Friday, September 17, 2021, at 12:00 AM UTC
Root cause: A compatibility issue between macOS 11.6 and multi-account OneDrive for Business facilitation resulted in access issues for Mac users attempting to access multiple accounts from a single device.
This is the final update for the event.