Admins are unable to change OneDrive for Business user storage limits

Incident
August 25, 3:07pm

Admins are unable to change OneDrive for Business user storage limits

Status: closed
Start: August 25, 5:03am
End: August 25, 3:07pm
Duration: 10 hours 3 minutes
Affected Components:
OneDrive
Update

August 25, 5:03am

August 25, 5:03am

Title: Some admins are unable to change OneDrive for Business user storage limits
User Impact: Admins are unable to change OneDrive for Business user storage limits.
Current status: We're investigating a potential issue where admins are unable to change OneDrive for Business user storage limits. We'll provide an update within 30 minutes.

Update

August 25, 5:14am

August 25, 5:14am

Current status: We’re reviewing details provided in the support case to determine the next steps needed to resolve this issue.
Scope of impact: Impact is specific to admins who are served through the affected Asia-Pacific infrastructure.
Next update by: Wednesday, August 25, 2021, at 12:30 PM UTC

Update

August 25, 7:27am

August 25, 7:27am

Current status: We're analyzing Unified Logging Service (ULS) logs to isolate the source of the issue and develop a mitigation plan.
Scope of impact: Impact is specific to admins who are served through the affected Asia-Pacific infrastructure.
Next update by: Wednesday, August 25, 2021, at 2:30 PM UTC

Update

August 25, 8:25am

August 25, 8:25am

Current status: We're continuing to analyze Unified Logging Service (ULS) logs from our reproduction of the issue, to determine our next troubleshooting steps.
Scope of impact: Impact is specific to admins who are served through the affected infrastructure.
Next update by: Wednesday, August 25, 2021, at 6:00 PM UTC

Update

August 25, 12:01pm

August 25, 12:01pm

Current status: Our analysis of the ULS data from our reproduction of the issue is ongoing. In parallel, we're reviewing recent service changes to further our efforts to isolate the source of the problem.
Scope of impact: Impact is specific to admins who attempt to change OneDrive for Business user storage limits.
Next update by: Wednesday, August 25, 2021, at 9:30 PM UTC

Resolved

August 25, 3:07pm

August 25, 3:07pm

Final status: Following our ULS data analysis, we've identified a recent service update that was preventing admins from changing OneDrive for Business user storage limits. We've reverted the recent update, and confirmed via internal telemetry that it has successfully remediated impact.
Scope of impact: Impact was specific to admins who were attempting to change OneDrive for Business user storage limits.
Start time: Friday, August 13, 2021, at 1:22 AM UTC
End time: Wednesday, August 25, 2021, at 8:07 PM UTC
Root cause: A recent service update designed to redistribute load within the SharePoint Online Directory resulted in impact.
Next steps: - We're reviewing our update procedures to better understand why the change produced impact and to identify similar issues during our development and testing cycles.
This is the final update for the event.